<html lang="en_US"><head><meta charset="utf-8"><meta http-equiv="X-UA-Compatible" content="IE=edge"><meta name="viewport" content="width=device-width, initial-scale=1"> <!-- Begin Jekyll SEO tag v2.7.1 --><title>The 32 Best IDEs/Text Editors for C++ | Terminal Root</title><meta name="generator" content="Jekyll v3.9.0" /><meta property="og:title" content="The 32 Best IDEs/Text Editors for C++" /><meta name="author" content="Marcos Oliveira" /><meta property="og:locale" content="en_US" /><meta name="description" content="A definitive list for Linux, macOS and Windows and one that is also suitable for other programming languages!" /><meta property="og:description" content="A definitive list for Linux, macOS and Windows and one that is also suitable for other programming languages!" /><link rel="canonical" href="https://en.terminalroot.com.br/the-32-best-ides-text-editors-for-cpp/" /><meta property="og:url" content="https://en.terminalroot.com.br/the-32-best-ides-text-editors-for-cpp/" /><meta property="og:site_name" content="Terminal Root" /><meta property="og:image" content="https://en.terminalroot.com.br/assets/img/cpp/cpp-editores-min.jpg" /><meta property="og:type" content="article" /><meta property="article:published_time" content="2021-12-07T12:15:39+00:00" /><meta name="twitter:card" content="summary_large_image" /><meta property="twitter:image" content="https://en.terminalroot.com.br/assets/img/cpp/cpp-editores-min.jpg" /><meta property="twitter:title" content="The 32 Best IDEs/Text Editors for C++" /> <script type="application/ld+json"> {"mainEntityOfPage":{"@type":"WebPage","@id":"https://en.terminalroot.com.br/the-32-best-ides-text-editors-for-cpp/"},"description":"A definitive list for Linux, macOS and Windows and one that is also suitable for other programming languages!","url":"https://en.terminalroot.com.br/the-32-best-ides-text-editors-for-cpp/","@type":"BlogPosting","image":"https://en.terminalroot.com.br/assets/img/cpp/cpp-editores-min.jpg","headline":"The 32 Best IDEs/Text Editors for C++","dateModified":"2021-12-07T12:15:39+00:00","datePublished":"2021-12-07T12:15:39+00:00","author":{"@type":"Person","name":"Marcos Oliveira"},"@context":"https://schema.org"}</script> <!-- End Jekyll SEO tag --><link rel="apple-touch-icon" sizes="180x180" href="/assets/img/icons/favicon.png?v=qA3OXqyw77"><link rel="icon" type="image/png" sizes="32x32" href="/assets/img/icons/favicon.png?v=qA3OXqyw77"><link rel="icon" type="image/png" sizes="16x16" href="/assets/img/icons/favicon.png?v=qA3OXqyw77"><link rel="manifest" href="/assets/img/icons/manifest.json?v=qA3OXqyw77"><link rel="mask-icon" href="/assets/img/icons/favicon.png?v=qA3OXqyw77" color="#5bbad5"> <!--[if IE]><link rel="shortcut icon" href="/assets/img/icons/favicon.png?v=qA3OXqyw77"><![endif]--><link rel="shortcut icon" href="/assets/img/icons/favicon.png?v=qA3OXqyw77"><meta name="apple-mobile-web-app-title" content="Terminal Root"><meta name="application-name" content="Terminal Root"><meta name="msapplication-config" content="/assets/img/icons/browserconfig.xml?v=qA3OXqyw77"><meta name="theme-color" content="#ffffff"><style class="inlineCSS">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</style><link rel="preload" href="/assets/css/main.css" as="style" onload="this.rel='stylesheet'"> <noscript><link rel="stylesheet" href="/assets/css/main.css"></noscript> <script type="text/javascript"> /*! loadCSS. [c]2017 Filament Group, Inc. MIT License */ (function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}} var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1} return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia} if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)} setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return} var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}} if(typeof exports!=="undefined"){exports.loadCSS=loadCSS} else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this)) </script> <!-- Google Adsense --> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script> (adsbygoogle = window.adsbygoogle || []).push({ google_ad_client: "ca-pub-2838251107855362", enable_page_level_ads: true }); </script> <!-- GOOGLE ADSENSE para Anúncios Automáticos --> <script async custom-element="amp-auto-ads" src="https://cdn.ampproject.org/v0/amp-auto-ads-0.1.js"> </script> <!-- GOOGLE ANALYTICS --> <!-- Global site tag (gtag.js) - Google Analytics --> <script async src="https://www.googletagmanager.com/gtag/js?id=UA-75725905-2"></script> <script> window.dataLayer = window.dataLayer || []; function gtag(){dataLayer.push(arguments);} gtag('js', new Date()); gtag('config', 'UA-75725905-2'); </script></head><body class="site"> <amp-auto-ads type="adsense" data-ad-client="ca-pub-2838251107855362"> </amp-auto-ads><header class="header" itemscope itemtype="http://schema.org/SiteNavigationElement" aria-label="Main navigation"><div class="container"><div class="header__inner"> <a class="header__logo" href="/"><div class="header__logo--container"> <img src="/assets/img/icons/logo.png" alt="Terminal Root" title="terminalroot"></div></a><nav class="header__links"><div class="container header__links-wrapper"> <a class="header__link" href="/" itemprop="url"><span itemprop="name">Home</span></a> <a class="header__link" href="/about" itemprop="url"><span itemprop="name">About</span></a> <a class="header__link" href="/contact" itemprop="url"> <span itemprop="name">Contact</span> </a></div></nav><div class="header__toggle"> <span></span> <span></span> <span></span></div></div></div></header><div class="hero lazyload" data-bg="https://en.terminalroot.com.br/assets/img/posts/../cpp/cpp-editores-min.jpg"><div class="hero__wrap"><h1 class="hero__title">The 32 Best IDEs/Text Editors for C++</h1><p class="hero__meta"> <span> <time>07 Dec 2021</time>&nbsp; </span> <span> 15 mins read &nbsp; </span></p></div></div></div><main class="site__content"><div class="container"><article class="post-content" itemprop="articleBody"> <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-2838251107855362" data-ad-slot="7504231210"></ins> <script> (adsbygoogle = window.adsbygoogle || []).push({}); </script><p><img src="/assets/img/cpp/cpp-editores-min.jpg" alt="The 32 Best IDEs/Text Editors for C++" /></p><hr /><p>Not everyone has the same tastes and when it comes to development <a href="https://en.terminalroot.com.br/compile-for-c-cpp-with-lua-based-xmake/">C++</a> the form and environment can vary from person to person.</p><p>Many are not satisfied with the development environment they use or plan to test others to see if things run better.</p><p>Based on that I decided to build the biggest list of Text Editors and IDEs for <a href="https://en.terminalroot.com.br/i-created-a-c-financial-management-program-for-linux-and-windows/">C++</a> where many of these alternatives will also work for other <a href="https://en.terminalroot.com.br/hello-world-in-25-programming-languages-proposal-docs-and-links/">programming languages</a>, mainly for <a href="https://en.terminalroot.com.br/examples-of-functions-fread-fwrite-remove-and-others-in-c/">Linguagem C</a>.</p><p>So let’s go to the list because it’s nothing small! 😃</p><hr /><h1 id="01-neovim">01. Neovim</h1><p><img src="/assets/img/cpp/editors/neovim.jpg" alt="Neovim" /></p><p><a href="https://en.terminalroot.com.br/all-about-neovim-with-lua-how-to-customize-from-zero/">Neovim</a> is a fork of <a href="https://en.terminalroot.com.br/how-to-customize-your-vim-from-zero-to-c-cpp-ubuntu-cinnamon/">Vim</a> with the objective of improving the code base, allowing easier API implementation, better user experience and plug-in implementation.</p><p>In addition to <a href="https://en.terminalroot.com.br/examples-of-functions-fread-fwrite-remove-and-others-in-c/">C</a> and <a href="https://en.terminalroot.com.br/i-created-a-c-financial-management-program-for-linux-and-windows/">C++</a> it is also suitable for any other <a href="https://en.terminalroot.com.br/hello-world-in-25-programming-languages-proposal-docs-and-links/">programming language</a>.</p><p>We have a complete series about <strong>Neovim</strong> which includes: Installation, Customization, Installation of plugins and more and you can start it from <a href="https://en.terminalroot.com.br/all-about-neovim-with-lua-how-to-customize-from-zero/">this link</a> .</p><p><a href="https://neovim.io/">Neovim Official Page</a></p><!-- QUADRADO --> <script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><p><ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-2838251107855362" data-ad-slot="5351066970"></ins> <script> (adsbygoogle = window.adsbygoogle || []).push({}); </script></p><hr /><h1 id="02-clion">02. CLion</h1><p><img src="/assets/img/cpp/editors/clion.jpg" alt="CLion" /></p><p><a href="https://www.jetbrains.com/clion/">CLion</a>, from the Czechoslovakia company JetBrains, formerly IntelliJ Software, is an IDE <a href="https://en.terminalroot.com.br/examples-of-functions-fread-fwrite-remove-and-others-in-c/">C</a> and <a href="https://en.terminalroot.com.br/i-created-a-c-financial-management-program-for-linux-and-windows/">C++</a> for <a href="https://en.terminalroot.com.br/large-list-of-gnulinux-commands-by-categories/">Linux</a>, <a href="https://en.terminalroot.com.br/how-to-install-macos-on-virtualbox-on-linux/">macOS</a> and <a href="https://en.terminalroot.com.br/how-to-install-powershell-on-ubuntu-and-getting-started/">Windows</a> integrated with the compilation system <a href="https://en.terminalroot.com.br/how-to-compile-your-programs-with-cmake/">CMake</a> .</p><p>It supports <a href="https://en.terminalroot.com.br/gcc-vs-llvm-which-is-the-best-compiler/">GNU Compiler Collection (GCC)</a> and <a href="https:// terminalroot.com.br/2019/12/gcc-vs-llvm-qual-eo-melhor-compilador.html">Clang</a> and debugger GDB , LLDB and Google Test . In addition to <strong>C</strong> and <strong>C++</strong>, CLion supports other languages directly or through plug-ins: Kotlin, <a href="https://en.terminalroot.com.br/the-30-best-python-libraries-and-packages-for-beginners/">Python</a>, <a href="https://en.terminalroot.com.br/redox-os-a-system-written-in-rust-installation-and-concepts/">Rust</a>, Swift and others.</p><p><a href="https://www.jetbrains.com/clion/">CLion Official Page</a></p><hr /><h1 id="03-vim">03. Vim</h1><p><img src="/assets/img/cpp/editors/vim.jpg" alt="Vim" /></p><p><a href="https://en.terminalroot.com.br/how-to-customize-your-vim-from-zero-to-c-cpp-ubuntu-cinnamon/">Vim</a> (a contraction of <strong>V</strong>i <strong>IM</strong>proved, in Portuguese <strong>Vi Improved</strong>) is a clone of the text editor program <a href="https://pt.wikipedia.org/wiki/Vi">vi</a> to <a href="https://en.terminalroot.com.br/the-13-best-shell-for-your-linux-or-unix/">Unix</a> by Bill Joy.</p><p>It was written by <a href="https://moolenaar.net/">Bram Moolenaar</a> based on the source for a port of Stevie editor to Amiga . <a href="https://en.terminalroot.com.br/how-to-customize-your-vim-from-zero-to-c-cpp-ubuntu-cinnamon/">Vim</a> is intended for use from either a command line interface or a standalone application in a graphical user interface.</p><p>It is Free Software and open source and is released under a license that includes some charitable clauses, encouraging users who join the software to consider donating to Ugandan children. The license is compatible with the GNU General Public License through a special clause allowing the distribution of modified copies “under the GNU GPL version 2 or any later version “.</p><p><a href="https://www.vim.org/">Vim Official Page</a></p><hr /><h1 id="04-emacs">04. Emacs</h1><p><img src="/assets/img/cpp/editors/emacs.jpg" alt="Emacs" /></p><p><a href="https://www.gnu.org/software/emacs/">Emacs</a> is a family of text editors that are characterized by their extensibility. The manual for the most widely used variant, GNU Emacs , describes it as “the extensible, customizable, self-documenting real-time display editor”. Development of the first Emacs began in the mid-1970s, and work on its direct descendant, GNU Emacs, actively continues into 2021 .</p><p><a href="https://emacsporn.tumblr.com/">Emacs</a> has more than 10,000 <a href="https://en.terminalroot.com.br/large-list-of-gnulinux-commands-by-categories/">commands</a> built in and its user interface allows the user to combine these commands into macros to automate the work.</p><p>Emacs implementations usually have a dialect of the <strong>Lisp</strong> programming language. Extensions have been written to manage email, files, outlines, and <a href="https://en.terminalroot.com.br/feed">RSS feeds</a>, as well as clones of ELIZA, Pong, Conway’s Life, Snake and Tetris.</p><p>Emacs is considered by many to be <em>an operating system</em> (contains irony). The most popular and most ported version of Emacs is GNU Emacs, which was created by Richard Stallman for the GNU Project.</p><p><a href="https://www.gnu.org/software/emacs/">Official Emacs Page</a></p><hr /><h1 id="05-spacemacs">05. Spacemacs</h1><p>Spacemacs is a configuration framework for GNU Emacs . It can take advantage of all the features of GNU Emacs, including graphical and command-line user interfaces, and run on the <a href="https://en.wikipedia.org/wiki/X_Window_System">X Window System</a> and a <a href="https://en.terminalroot.com.br/the-10-best-terminal-emulators-for-your-linux/">terminal</a> <a href="https://en.terminalroot.com.br/the-13-best-shell-for-your-linux-or-unix/">shell</a> of Unix . It is free and open source software (FOSS) released under the GPL-3.0 or later license.</p><p>In 2021 , his GitHub repository was tagged with over 21,100 stars and over 11,300 commits .</p><p><a href="https://www.spacemacs.org/">Spacemacs Official Page</a></p><hr /><h1 id="06-kdevelop">06. KDevelop</h1><p><img src="/assets/img/cpp/editors/kdevelop.jpg" alt="KDevelop" /></p><p><a href="https://www.kdevelop.org/">KDevelop</a> is a free and open source integrated development environment (IDE) for Unix and Windows type computer operating systems.</p><p>It provides editing, navigation, and debugging capabilities for various programming languages ​​and integration with build automation and version control systems using a plugin-based architecture.</p><p>KDevelop 5 has parser backends for <a href="https://en.terminalroot.com.br/examples-of-functions-fread-fwrite-remove-and-others-in-c/">C</a> , <a href="https://en.terminalroot.com.br/i-created-a-c-financial-management-program-for-linux-and-windows/">C++</a> , Objective-C , OpenCL and <a href="https://en.terminalroot.com.br/create-window-for-html5-with-javascript/">JavaScript</a>/QML , with plugins that support <a href="https://en.terminalroot.com.br/tested-the-performance-of-10-programming-languages/">PHP</a> , Python 3 and <a href="https://en.terminalroot.com.br/how-to-properly-install-ruby-bundler-and-jekyll-on-ubuntu-linux/">Ruby</a> . Basic syntax highlighting and code folding are available for dozens of other source code and markup formats, but without semantic analysis.</p><p><a href="https://www.kdevelop.org/download">KDevelop</a> is part of the KDE project and is based on KDE Frameworks and <a href="https://en.terminalroot.com.br/i-created-a-c-financial-management-program-for-linux-and-windows/">Qt</a> . The C/C ++ backend uses Clang to provide accurate information, even for very complex code bases.</p><p>You can install the <a href="https://en.terminalroot.com.br/meet-the-app-get-an-appimages-manager-via-command-line/">AppImage</a> and use KDevelop as follows:</p><div class="language-sh highlighter-rouge"><div class="highlight"><pre class="highlight"><code>wget <span class="nt">-O</span> KDevelop.AppImage https://download.kde.org/stable/kdevelop/5.6.1/bin/linux/KDevelop-5.6.1-x86_64.AppImage
<span class="nb">chmod</span> +x KDevelop.AppImage
./KDevelop.AppImage
</code></pre></div></div><p><a href="https://www.kdevelop.org/">KDevelop Official Page</a></p><!-- RETANGULO LARGO 2 --> <script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><p><ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-2838251107855362" data-ad-slot="8549252987"></ins> <script> (adsbygoogle = window.adsbygoogle || []).push({}); </script></p><hr /><h1 id="07-geany">07. Geany</h1><p><img src="/assets/img/cpp/editors/geany.jpg" alt="Geany" /></p><p>Geany is a cross-platform text editor developed in <a href="https://en.terminalroot.com.br/learn-to-create-a-graphical-application-with-c-and-gtkmm/">GTK+</a> that has basic functions for an integrated development environment (IDE), licensed under the GNU GPL version 2.</p><p>It was developed with the intention of providing a light, fast IDE with few dependencies. Geany is available for several operating systems, such as <a href="https://en.terminalroot.com.br/openbsd-dual-boot-with-linux-single-partition/">BSD</a>, <a href="https://en.terminalroot.com.br/top-10-best-code-editors-for-linux/">Linux</a>, <a href="https://en.terminalroot.com.br/how-to-install-macos-on-virtualbox-on-linux/"> macOS</a>, Solaris and <a href="https://en.terminalroot.com.br/how-to-install-powershell-on-ubuntu-and-getting-started/">Windows</a> .</p><p>In fact, it can run on any platform that supports the <a href="https://en.terminalroot.com.br/learn-to-create-a-graphical-application-with-c-and-gtkmm/">GTK</a> libraries ), as it requires only the GTK2 runtime libraries.</p><p><a href="https://www.geany.org/">Geany’s Official Page</a></p><hr /><h1 id="08-dev-c">08. Dev C++</h1><p><img src="/assets/img/cpp/editors/devcpp.jpg" alt="Dev C++" /></p><p><a href="http://orwelldevcpp.blogspot.com/">Dev-C++</a> (also known as Dev-Cpp) is a free integrated development environment that uses the GNU project’s compilers to compile programs for the Microsoft Windows operating system. It supports C and C++ programming languages, and has the entire ANSI C library. The IDE is written in Delphi.</p><p><a href="http://orwelldevcpp.blogspot.com/">Official Dev C++ Page</a></p><hr /><h1 id="09-codeblocks">09. Code::Blocks</h1><p><img src="/assets/img/cpp/editors/codeblocks.jpg" alt="Code::Blocks" /></p><p><a href="http://www.codeblocks.org/">Code::Blocks</a> is an open-source, cross-platform integrated development environment. It was developed in <a href="https://en.terminalroot.com.br/i-created-a-c-financial-management-program-for-linux-and-windows/">C++</a>, using wxWidgets. Its architecture is plugin-oriented, so its functionality is defined by the plugins provided to it.</p><p>Code::Blocks is designed for C/C++ and Fortran development, and can also be used to create ARM, AVR, D (programming language), DirectX, FLTK, GLFW, GLUT, GTK+, Irrlicht, Lightfeather, MATLAB, OGRE, OpenGL, Qt, SDL, SFML, STL, SmartWin and programs or applications with wx, although in certain cases the installation of SDKs or frameworks is necessary.</p><p>Code::Blocks is being developed for Windows and Linux. Some users have also successfully compiled Code::Blocks for FreeBSD and <a href="https://en.terminalroot.com.br/how-to-install-macos-on-virtualbox-on-linux/">macOS</a> .</p><p><a href="http://www.codeblocks.org/">Official Code::Blocks Page</a></p><hr /><h1 id="10-notepadqq">10. Notepadqq</h1><p><img src="/assets/img/cpp/editors/notepadqq.jpg" alt="Notepadqq" /></p><p>Notepadqq is an editor similar to <a href="https://notepad-plus-plus.org/">Notepad++</a> for <a href="https://en.terminalroot.com.br/large-list-of-gnulinux-commands-by-categories/">Linux</a>.</p><p>It helps developers by providing everything you can expect from a general purpose text editor like syntax highlighting for over 100 different languages, folding code folding, color schemes, file tracking, multiple selection and much more.</p><p>You can search text using the power of <a href="https://en.terminalroot.com.br/30-examples-of-the-sed-command-with-regex/">regular expressions</a>. You can organize documents side by side. You can use real-time highlighting to quickly find nearby tags.</p><p><a href="https://notepadqq.com/">Notepadqq Official Page</a></p><hr /><h1 id="11-qt-creator">11. Qt Creator</h1><p><img src="/assets/img/cpp/editors/qtcreator.jpg" alt="Qt Creator" /></p><p><a href="https://en.terminalroot.com.br/i-created-a-c-financial-management-program-for-linux-and-windows/">Qt Creator</a> is a cross-platform IDE that brings with it Qt <a href="https://en.wikipedia.org/wiki/Software_development_kit">SDK</a>. The IDE Qt Creator package offers fast and easy cross-platform application development.</p><p><a href="https://www.qt.io/">Qt Creator Official Page</a></p><hr /><h1 id="12-scite">12. SciTE</h1><p><img src="/assets/img/cpp/editors/scite.jpg" alt="SciTE" /></p><p><a href="https://www.scintilla.org/SciTE.html">SciTE</a> or <a href="https://www.scintilla.org/">SCIntilla</a> is a cross-platform text editor written by Neil Hodgson using the Scintilla editing component . It is licensed under a minimal version of the Historic Permission Disclaimer.</p><p>It’s lightweight and built to be fast, it’s primarily designed for source code editing, and it performs syntax highlighting and built-in function reference for many different languages.</p><!-- RETANGULO LARGO --> <script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <!-- Informat --><p><ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-2838251107855362" data-ad-slot="2327980059" data-ad-format="auto" data-full-width-responsive="true"></ins> <script> (adsbygoogle = window.adsbygoogle || []).push({}); </script></p><p>There is a standalone <code class="language-plaintext highlighter-rouge">.exe</code> available for Microsoft Windows, intended for USB flash drives . SciTE shares some features with other editors based on the Scintilla editing component.</p><p><a href="https://www.scintilla.org/SciTE.html">Official SciTE Page</a></p><hr /><h1 id="13-gamma">13. Gamma</h1><p><img src="/assets/img/cpp/editors/gama.jpg" alt="Gamma" /></p><p><a href="https://gitlab.com/hamadmarri/gamma-text-editor">Gamma (Γ)</a> is a lightweight text editor. It is intended to be an alternative to <a href="https://en.terminalroot.com.br/display-the-gedit-preferences-menu/">Gedit</a> or <a href="https://notepad-plus-plus.org/">Notepad++</a>.</p><p>Although the current implementation is tested on <a href="https://en.terminalroot.com.br/how-auto-complete-works-in-shell-linux/">Linux</a> with desktop environment <a href="https://en.terminalroot.com.br/the-15-best-extensions-for-your-gnome/">GNOME</a>, it it can also be run on <a href="https://en.terminalroot.com.br/large-list-of-gnulinux-commands-by-categories/">Linux</a>, <a href="https://en.terminalroot.com.br/top-5-best-git-clients-for-linux-mac-and-windows/">Windows</a> and <a href="https:// terminalroot.com.br/tags/#macos">Mac</a> if the dependencies are installed (see the Dependencies section below).</p><p>Gamma uses <a href="https://www.gtk.org/">GTK3</a> ,cross-platform GUI toolkit, and PyGObject which is a <a href="https://en.terminalroot.com.br/basic-python-script-for-learning/">Python</a> package which provides links to GObject-based libraries like GTK, GStreamer, WebKitGTK, GLib, GIO and more.</p><p>We have a full article on Gamma, go for more installation details: <a href="https://en.terminalroot.com.br/meet-the-new-gamma-text-editor/">Meet the new Gamma text editor</a>.</p><p><a href="https://gitlab.com/hamadmarri/gamma-text-editor">Official Gamma Page</a></p><hr /><h1 id="14-codelite">14. CodeLite</h1><p><img src="/assets/img/cpp/editors/codelite.jpg" alt="CodeLite" /></p><p>CodeLite is a free, open-source, cross-platform IDE for the programming language <a href="https://en.terminalroot.com.br/examples-of-functions-fread-fwrite-remove-and-others-in-c/">C</a>/<a href="https://en.terminalroot.com.br/using-curl-with-cpp/">C++</a> , but can also be used for PHP, and JavaScript (Node.js).</p><p><a href="https://codelite.org/">CodeLite Official Page</a></p><hr /><h1 id="15-gnat-studio">15. GNAT Studio</h1><p><img src="/assets/img/cpp/editors/gnatstudio.jpg" alt="GNAT Studio" /></p><p><a href="https://github.com/AdaCore/gps">GNAT Studio</a> is a free multi-language integrated development environment (IDE). GNAT Studio uses compilers from the <a href="https://en.terminalroot.com.br/gcc-vs-llvm-which-is-the-best-compiler/">GNU Compiler Collection</a> , whose name comes from GNAT , the GNU compiler for the Ada programming language, but also for other languages ​​like <strong>C/C++</strong> .</p><p>GNAT Studio is cross-platform, running on[Linux , FreeBSD , <a href="https://en.terminalroot.com.br/how-to-install-powershell-on-ubuntu-and-getting-started/">Windows</a> , <a href="https://en.terminalroot.com.br/how-to-install-macos-on-virtualbox-on-linux/">macOS</a> and Solaris .</p><p>GNAT Studio uses GTK+ as its toolkit. widget for your graphical user interface. Distributed under the GNU General Public License, GNAT Studio is Free Software .</p><p><a href="https://www.adacore.com/gnatpro/toolsuite/gnatstudio">GNAT Studio Official Page</a></p><hr /><h1 id="16-slickedit">16. SlickEdit</h1><p><img src="/assets/img/cpp/editors/slickedit.jpg" alt="SlickEdit" /></p><p>SlickEdit , formerly known as Visual SlickEdit , is a cross-platform source code editor, text editor IDE, developed by SlickEdit, Inc. SlickEdit supports Integrated debuggers for GNU C/C++ , Java , WinDbg , Clang C/C++ LLDB, Groovy , Google Go , Python , Perl , Ruby , PHP , Xcode and Android JVM / NDK.</p><p><a href="https://www.slickedit.com/">Official SlickEdit Page</a></p><hr /><h1 id="17-turbo">17. Turbo</h1><p><img src="/assets/img/cpp/editors/turbo.jpg" alt="Turbo" /></p><p>Turbo is an experimental text editor for the terminal, based on Neil Hodgson’s Scintilla code editing component and the Turbo Vision application framework and uses the NCURSES library.</p><p>It was created to demonstrate the new features of Turbo Vision. In particular, it served as a testing ground for Turbo Vision’s Unicode features.</p><p>As a text editor, Turbo is intended to be intuitive and easy to use. Usability and productivity are its other two big goals, although it hasn’t gotten that far yet. And just because it’s a Turbo Vision app, it offers a vintage look.</p><p>We have a full article on Turbo: <a href="https://en.terminalroot.com.br/install-turbo-editor-for-c-cpp-style-turbo-vision/">Install the Turbo editor for C/C++ and kill Turbo Vision</a></p><p><a href="https://github.com/magiblot/turbo">Turbo Official Page</a></p><hr /><h1 id="18-anjuta">18. Anjuta</h1><p><img src="/assets/img/cpp/editors/anjuta.jpg" alt="Anjuta" /></p><p><a href="http://anjuta.org/">Anjuta</a> is an Integrated Development Environment for C and C++ on GNU/Linux. It was written for GTK+/GNOME and supports many advanced capabilities like project management and a powerful source code editor. Anjuta is free software distributed under the GPL license.</p><p><a href="https://gitlab.gnome.org/GNOME/anjuta">Anjuta Official Page</a></p><hr /><h1 id="19-vscodium">19. VSCodium</h1><p><img src="/assets/img/cpp/editors/vscodium.jpg" alt="VSCodium" /></p><p><a href="https://vscodium.com/">VSCodium</a> is an editor identical to Microsoft’s <a href="https://code.visualstudio.com/">Visual Studio Code</a> but the only differences is that the icon is different and best of all, it has no <em>trackers</em> and no telemetry to measure and know what you develop.</p><!-- MINI ANÚNCIO --> <script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <!-- Games Root --><p><ins class="adsbygoogle" style="display:inline-block;width:730px;height:95px" data-ad-client="ca-pub-2838251107855362" data-ad-slot="5351066970"></ins> <script> (adsbygoogle = window.adsbygoogle || []).push({}); </script></p><p>It is available for <a href="http://terminalroot.com.br/2019/04/como-acessar-o-windows-pelo-linux-com-metasploit.html">Windows</a>, <a href="http://terminalroot. com.br/2018/03/como-instalar-o-mac-os-x-em-virtualbox-no-linux.html">macOS</a> and <a href="http://cse.google.com.br/cse?cx =004473188612396442360:qs2ekmnkweq&amp;q=Linux">Linux</a>. It comes with built-in support for <a href="http://terminalroot.com.br/2018/01/rodando-javascript-via-terminal-e-shell-via-js.html">JavaScript</a>, <a href="https:// /www.typescriptlang.org/">TypeScript</a> and <a href="https://nodejs.org">Node.js</a> and has a rich ecosystem of extensions for other languages ​​(such as C++, C#, Java, Python, PHP, Go) and times. execution (such as .NET and Unity).</p><p>VSCodium natively supports <a href="http://terminalroot.com.br/git">Git</a> and is Open Source Free Software licensed under the <a href="https://opensource.org/licenses/MIT">MIT License</a> .</p><p><a href="https://vscodium.com/">VSCodium Official Page</a></p><hr /><h1 id="20-komodo-ide">20. Komodo IDE</h1><p><img src="/assets/img/cpp/editors/komodoide.jpg" alt="Komodo IDE" /></p><p><a href="https://www.activestate.com/products/komodo-ide/">Komodo IDE</a> is an integrated development environment (IDE) for dynamic programming languages. It was created in May 2000. Many of Komodo’s features came from a built-in Python interpreter.</p><p>Komodo IDE uses codebase from Mozilla and Scintilla as they share several features and support the same languages ​​(including Python, Perl, PHP, Ruby, Tcl, SQL, Smarty, CSS, HTML and XML) and operating systems (Linux, OS X, and Windows).</p><p><a href="https://www.activestate.com/products/komodo-ide/">Komodo IDE Official Page</a></p><hr /><h1 id="21-vs-code">21. VS Code</h1><p><img src="/assets/img/cpp/editors/vscode.jpg" alt="VS Code" /></p><p>This one needs no information most know it well, as it is the <em>flagship</em> Microsoft text editor/IDE. We have another article about it:</p><ul><li><a href="https://en.terminalroot.com.br/install-this-vs-code-extension-to-comment-out-ascii-blocks/">Install this VS Code extension to comment blocks in ASCII</a></li></ul><p>VS Code now also has an online version that can be accessed at: <a href="https://vscode.dev/">https://vscode.dev/</a>.</p><p><a href="https://code.visualstudio.com/">VS Code Official Page</a></p><hr /><h1 id="22-xcode">22. Xcode</h1><p><img src="/assets/img/cpp/editors/xcode.jpg" alt="Xcode" /></p><p>Xcode is Apple’s integrated development environment (IDE) for macOS. Or that is, it only works on <a href="https://en.terminalroot.com.br/how-to-install-macos-on-virtualbox-on-linux/">macOS</a>.</p><p><a href="https://developer.apple.com/xcode/">Xcode Official Page</a></p><hr /><h1 id="23-visual-studio">23. Visual Studio</h1><p><img src="/assets/img/cpp/editors/visualstudio.jpg" alt="Visual Studio" /></p><p><a href="https://visualstudio.microsoft.com/en-us/">Microsoft Visual Studio</a> is a Microsoft integrated development environment (IDE) for software development specifically dedicated to the .NET Framework and Visual Basic (VB) languages , C, C++, C# (C Sharp) and F# (F Sharp). It is also a web development product, using ASP.NET platform such as websites, web apps, web services and mobile apps.</p><p><a href="https://visualstudio.microsoft.com/en-us/">Visual Studio Official Page</a></p><hr /><h1 id="24-gedit">24. Gedit</h1><p>Gedit is a GNOME text editor. Similar to Windows Notepad, but with developer features like:</p><ul><li>Line numbering</li><li>Automatic indentation</li><li>Syntax highlighting</li><li>Spell check</li></ul><p><a href="https://wiki.gnome.org/Apps/Gedit">Official Gedit Page</a></p><hr /><h1 id="25-ultraedit">25. Ultraedit</h1><p><img src="/assets/img/cpp/editors/ultraedit.jpg" alt="UltraEdit" /></p><p>UltraEdit is a commercial text editor for Microsoft Windows and Linux operating systems.</p><p><a href="https://www.ultraedit.com/">Ultraedit Official Page</a></p><hr /><h1 id="26-atom">26. Atom</h1><p><img src="/assets/img/cpp/editors/atom.jpg" alt="Atom" /></p><p>Atom is an open source text editor available for Linux, macOS and Microsoft Windows platforms, developed by GitHub under the MIT license.</p><p><a href="https://atom.io/">Atom Official Page</a></p><hr /><h1 id="27-sublime-text">27. Sublime Text</h1><p><img src="/assets/img/cpp/editors/sublimetext.jpg" alt="Sublime Text" /></p><p>Sublime Text is a cross-platform source code editor and <a href="https://en.wikipedia.org/wiki/Shareware">shareware</a> . It natively supports many programming languages ​​and markup languages.</p><p><a href="https://github.com/SublimeText">Sublime Text Official Page</a></p><hr /><h1 id="28-brackets">28. Brackets</h1><p><img src="/assets/img/cpp/editors/brackets.jpg" alt="Brackets" /></p><p>Brackets is a source code editor with a main focus on web development. Created by <strong>Adobe Systems</strong> , it is free and open source software licensed under the MIT license and is currently maintained on GitHub by open source developers.</p><p>You can install Brackets AppImage via <a href="https://en.terminalroot.com.br/meet-the-app-get-an-appimages-manager-via-command-line/">app-get</a>, a command-line package manager that serves to install AppImages, <a href="https://en.terminalroot.com.br/meet-the-app-get-an-appimages-manager-via-command-line/">click here</a> to learn more.</p><p><a href="https://brackets.io/">Official Brackets Page</a></p><hr /><h1 id="29-eclipse">29. Eclipse</h1><p><img src="/assets/img/cpp/editors/eclipse.jpg" alt="Eclipse" /></p><p>Eclipse is an IDE for Java development, but it supports several other languages ​​from plugins like C/C++, PHP, ColdFusion, Python, Scala and Kotlin. It was made in Java and follows the open source software development model.</p><p><a href="https://www.eclipse.org/">Eclipse Official Page</a></p><hr /><h1 id="30-netbeans">30. NetBeans</h1><p><img src="/assets/img/cpp/editors/netbeans.jpg" alt="NetBeans" /></p><p>NetBeans is an integrated development environment (IDE) for Java. NetBeans allows applications to be built from a set of modular software components called modules. NetBeans runs on Windows, macOS, Linux and Solaris. In addition to Java development, it has extensions for other languages ​​such as PHP , C , C ++ , HTML5 and JavaScript .</p><p><a href="https://netbeans.apache.org/">Official NetBeans Page</a></p><hr /><h1 id="31-ultimatetheide">31. Ultimate++/TheIDE</h1><p><img src="/assets/img/cpp/editors/ultimatepp.jpg" alt="TheIDE" /></p><p>Ultimate++ or U++ is a cross-platform C++ development application focused on programmers’ productivity and uses the U++ integrated development environment, TheIDE, to introduce modular concepts for C++ programming.</p><p><a href="https://www.ultimatepp.org/">Ultimatepp/TheIDE Official Page</a></p><hr /><h1 id="32-monodevelop">32. MonoDevelop</h1><p><img src="/assets/img/cpp/editors/monodevelop.jpg" alt="MonoDevelop" /></p><p>And to finish this list, let’s go to <a href="">MonoDevelop</a>, also known as Xamarin Studio, it’s an open-source integrated development environment for <a href="https://en.terminalroot.com.br/6-signs-that-reveal-you-are-a-true-linux-user/">Linux</a> , <a href="https://en.terminalroot.com.br/how-to-install-macos-on-virtualbox-on-linux/">macOS </a> and <a href="https://en.terminalroot.com.br/how-to-install-powershell-on-ubuntu-and-getting-started/">Windows</a> .</p><p><a href="https://www.monodevelop.com/">MonoDevelop Official Page</a></p><hr /><p>If you would like more alternatives and comparisons <a href="https://en.wikipedia.org/wiki/Comparison_of_integrated_development_environments">click here</a>.</p><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-2838251107855362" data-ad-slot="7504231210"></ins> <script> (adsbygoogle = window.adsbygoogle || []).push({}); </script></article><div class="post-content controls__inner"><div class="controls__item prev"> <span>Previous</span> <a href="/how-to-install-powershell-on-ubuntu-and-getting-started/"> <span> <svg xmlns="http://www.w3.org/2000/svg" width="6" height="11"><path fill="fillColor" d="M5.647 1.718c.37-.434.323-1.09-.106-1.465A1.016 1.016 0 0 0 4.095.36L.25 4.875a1.05 1.05 0 0 0 .017 1.378l3.95 4.407c.38.424 1.03.456 1.448.07a1.05 1.05 0 0 0 .07-1.468l-3.34-3.725 3.253-3.819z"/> </svg> </span> How to Install PowerShell o... </a></div><div class="controls__item next"></div></div></div><div class="comments"><div class="container"><div class="post-content"><h1> Add our feed: <a href="https://en.terminalroot.com.br/feed">https://en.terminalroot.com.br/feed</a> to:</h1><h2><a href="https://feedly.com/">Feedly</a></h2><!-- POSTS RELACIONADOS --> <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-2838251107855362" data-ad-slot="9652691879"></ins> <script> (adsbygoogle = window.adsbygoogle || []).push({}); </script><div id="disqus_thread"></div><script> var disqus_config = function () { this.page.url = 'https://en.terminalroot.com.br/the-32-best-ides-text-editors-for-cpp/'; this.page.identifier = 'https://en.terminalroot.com.br/the-32-best-ides-text-editors-for-cpp/'; }; (function() { var d = document, s = d.createElement('script'); s.src = 'https://terroo.disqus.com/embed.js'; s.setAttribute('data-timestamp', +new Date()); (d.head || d.body).appendChild(s); })(); </script> <noscript>Please enable JavaScript to view the comments.</noscript></div></div></div></main><footer class="footer"><div class="container"><nav class="social"> <a class="social__link" target="_blank" rel="noopener noreferrer" href="https://github.com/terroo"> <svg class="social__icon" viewBox="0 0 20 20" width="20px" height="20px"><path d="M7.999,0.431c-4.285,0-7.76,3.474-7.76,7.761 c0,3.428,2.223,6.337,5.307,7.363c0.388,0.071,0.53-0.168,0.53-0.374c0-0.184-0.007-0.672-0.01-1.32 c-2.159,0.469-2.614-1.04-2.614-1.04c-0.353-0.896-0.862-1.135-0.862-1.135c-0.705-0.481,0.053-0.472,0.053-0.472 c0.779,0.055,1.189,0.8,1.189,0.8c0.692,1.186,1.816,0.843,2.258,0.645c0.071-0.502,0.271-0.843,0.493-1.037 C4.86,11.425,3.049,10.76,3.049,7.786c0-0.847,0.302-1.54,0.799-2.082C3.768,5.507,3.501,4.718,3.924,3.65 c0,0,0.652-0.209,2.134,0.796C6.677,4.273,7.34,4.187,8,4.184c0.659,0.003,1.323,0.089,1.943,0.261 c1.482-1.004,2.132-0.796,2.132-0.796c0.423,1.068,0.157,1.857,0.077,2.054c0.497,0.542,0.798,1.235,0.798,2.082 c0,2.981-1.814,3.637-3.543,3.829c0.279,0.24,0.527,0.713,0.527,1.437c0,1.037-0.01,1.874-0.01,2.129 c0,0.208,0.14,0.449,0.534,0.373c3.081-1.028,5.302-3.935,5.302-7.362C15.76,3.906,12.285,0.431,7.999,0.431z"/></svg> </a> <a class="social__link" target="_blank" rel="noopener noreferrer" href="https://www.twitter.com/TerminalRootTV"> <svg class="social__icon" viewBox="0 0 20 20" width="20px" height="20px"><path d="M15.969,3.058c-0.586,0.26-1.217,0.436-1.878,0.515c0.675-0.405,1.194-1.045,1.438-1.809c-0.632,0.375-1.332,0.647-2.076,0.793c-0.596-0.636-1.446-1.033-2.387-1.033c-1.806,0-3.27,1.464-3.27,3.27 c0,0.256,0.029,0.506,0.085,0.745C5.163,5.404,2.753,4.102,1.14,2.124C0.859,2.607,0.698,3.168,0.698,3.767 c0,1.134,0.577,2.135,1.455,2.722C1.616,6.472,1.112,6.325,0.671,6.08c0,0.014,0,0.027,0,0.041c0,1.584,1.127,2.906,2.623,3.206 C3.02,9.402,2.731,9.442,2.433,9.442c-0.211,0-0.416-0.021-0.615-0.059c0.416,1.299,1.624,2.245,3.055,2.271 c-1.119,0.877-2.529,1.4-4.061,1.4c-0.264,0-0.524-0.015-0.78-0.046c1.447,0.928,3.166,1.469,5.013,1.469 c6.015,0,9.304-4.983,9.304-9.304c0-0.142-0.003-0.283-0.009-0.423C14.976,4.29,15.531,3.714,15.969,3.058z"/></svg> </a> <a class="social__link" target="_blank" rel="noopener noreferrer" href="https://www.facebook.com/groups/459813341567352/about/"> <svg class="social__icon" viewBox="0 0 20 20" width="20px" height="20px"><path d="M8 0C5.827 0 5.555.01 4.702.048 3.85.088 3.27.222 2.76.42a3.908 3.908 0 0 0-1.417.923c-.445.444-.72.89-.923 1.417-.198.51-.333 1.09-.372 1.942C.008 5.555 0 5.827 0 8s.01 2.445.048 3.298c.04.852.174 1.433.372 1.942.204.526.478.973.923 1.417.444.445.89.72 1.417.923.51.198 1.09.333 1.942.372.853.04 1.125.048 3.298.048s2.445-.01 3.298-.048c.852-.04 1.433-.174 1.942-.372a3.908 3.908 0 0 0 1.417-.923c.445-.444.72-.89.923-1.417.198-.51.333-1.09.372-1.942.04-.853.048-1.125.048-3.298s-.01-2.445-.048-3.298c-.04-.852-.174-1.433-.372-1.942a3.908 3.908 0 0 0-.923-1.417A3.886 3.886 0 0 0 13.24.42c-.51-.198-1.09-.333-1.942-.372C10.445.008 10.173 0 8 0zm0 1.44c2.136 0 2.39.01 3.233.048.78.036 1.203.166 1.485.276.374.145.64.318.92.598.28.28.453.546.598.92.11.282.24.705.276 1.485.038.844.047 1.097.047 3.233s-.01 2.39-.05 3.233c-.04.78-.17 1.203-.28 1.485-.15.374-.32.64-.6.92-.28.28-.55.453-.92.598-.28.11-.71.24-1.49.276-.85.038-1.1.047-3.24.047s-2.39-.01-3.24-.05c-.78-.04-1.21-.17-1.49-.28a2.49 2.49 0 0 1-.92-.6c-.28-.28-.46-.55-.6-.92-.11-.28-.24-.71-.28-1.49-.03-.84-.04-1.1-.04-3.23s.01-2.39.04-3.24c.04-.78.17-1.21.28-1.49.14-.38.32-.64.6-.92.28-.28.54-.46.92-.6.28-.11.7-.24 1.48-.28.85-.03 1.1-.04 3.24-.04zm0 2.452a4.108 4.108 0 1 0 0 8.215 4.108 4.108 0 0 0 0-8.215zm0 6.775a2.667 2.667 0 1 1 0-5.334 2.667 2.667 0 0 1 0 5.334zm5.23-6.937a.96.96 0 1 1-1.92 0 .96.96 0 0 1 1.92 0z"></path></svg> </a></nav><span>&copy; 2021 Terminal Root. All rights reserved.</span></div></footer><script async src="/assets/js/bundle.js"></script> <script> $(document).ready(function(){ $("a[href^='http']:not([href^='https://en.terminalroot.com.br'])").attr("target","_blank"); $("a[href^='http']:not([href^='https://en.terminalroot.com.br'])").attr("rel","noopener noreferrer"); })(jQuery); </script></body></html>
